[Numpy-discussion] OpenSuse 10.2 and numpy

Charles R Harris charlesr.harris at gmail.com
Thu Jan 4 11:42:35 CST 2007


On 1/4/07, Nils Wagner <nwagner at iam.uni-stuttgart.de> wrote:
>
> On Wed, 3 Jan 2007 22:37:39 -0700
>   "Charles R Harris" <charlesr.harris at gmail.com> wrote:
> > On 1/3/07, Nils Wagner <nwagner at iam.uni-stuttgart.de>
> >wrote:


<snip>


>
> I guess the problem is due to
>
> /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.5/../../../../x86_64-suse-linux/bin/ld:
> cannot find -lgcc_s
>
> /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.5/../../../../x86_64-suse-linux/bin/ld:
> cannot find -lgcc_s
>
> locate libgcc_s yields
>
> /lib64/libgcc_s.so.1
> /lib/libgcc_s.so.1
> /usr/lib64/gcc/x86_64-suse-linux/4.1.2/libgcc_s.so
>
> I am confused by the fact that lapack_lite.so is involved.
> I thought that it is obsolete if ATLAS is installed.
> Am I missing something ?


I suspect that ATLAS wasn't found, you might need to edit site.cfg to give
the build system some help. Also, a lot of the libgcc_s.so locations you
found are probably symlinks.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20070104/219b631e/attachment.html 


More information about the Numpy-discussion mailing list