[Numpy-discussion] recompiling needed for binary module after numpy 1.0

Sebastian Haase haase at msg.ucsf.edu
Fri Jan 5 15:50:14 CST 2007


Hi!
After I upgraded from numpy 1.0 to 1.0.1
I get an abort in a C-module:

RuntimeError: module compiled against version 1000002 of C-API but this
version of numpy is 1000009
Fatal Python error: numpy.core.multiarray failed to import... exiting.
/opt/bin/priithonN: line 37:  1409 Aborted                 $PY $*

I thought that within numpy 1.0 there was no recompile
for external C-modules needed !?

Please explain.

Thanks,
Sebastian Haase


More information about the Numpy-discussion mailing list