[Numpy-discussion] recompiling needed for binary module after numpy 1.0

Robert Kern robert.kern at gmail.com
Fri Jan 5 15:59:06 CST 2007


Sebastian Haase wrote:
> Hi!
> After I upgraded from numpy 1.0 to 1.0.1
> I get an abort in a C-module:
> 
> RuntimeError: module compiled against version 1000002 of C-API but this
> version of numpy is 1000009
> Fatal Python error: numpy.core.multiarray failed to import... exiting.
> /opt/bin/priithonN: line 37:  1409 Aborted                 $PY $*
> 
> I thought that within numpy 1.0 there was no recompile
> for external C-modules needed !?

Ummm, the number was bumped before the 1.0 release.

Bump of the version number:
  http://projects.scipy.org/scipy/numpy/changeset/3361

Tagging the 1.0 release:
  http://projects.scipy.org/scipy/numpy/changeset/3396/tags/1.0

Are you sure that you weren't upgrading from a beta instead of the 1.0 release?

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
 that is made terrible by our own mad attempt to interpret it as though it had
 an underlying truth."
  -- Umberto Eco


More information about the Numpy-discussion mailing list