[Numpy-discussion] recompiling needed for binary module after numpy 1.0

belinda thom bthom at cs.hmc.edu
Fri Jan 5 19:07:59 CST 2007


Sebastian,

I had the same problem awhile back; I'm curious---how'd you fix your  
mismatch (i.e. where'd you go to get code, did you run python  
setup?, ...). I realize these are very basic questions, but I've  
never installed anything from source (aside from using easy_install),  
so it would be nice to extend my very limited knowledge in this area.

Thx,

--b

============================


You are right again, of course !
Sorry for the noise - I should have just checked the date of my so
file (which is August 15)

At least I understood the "official numpy intention of version 1.0"
right then - just  checking ...

Thanks,
Sebastian.

On 1/5/07, Robert Kern <robert.kern at gmail.com> wrote:
 > Sebastian Haase wrote:
 > > Hi!
 > > After I upgraded from numpy 1.0 to 1.0.1
 > > I get an abort in a C-module:
 > >
 > > RuntimeError: module compiled against version 1000002 of C-API  
but this
 > > version of numpy is 1000009
 > > Fatal Python error: numpy.core.multiarray failed to import...  
exiting.
 > > /opt/bin/priithonN: line 37:  1409 Aborted                 $PY $*
 > >
 > > I thought that within numpy 1.0 there was no recompile
 > > for external C-modules needed !?
 >
 > Ummm, the number was bumped before the 1.0 release.
 >
 > Bump of the version number:
 >   http://projects.scipy.org/scipy/numpy/changeset/3361
 >
 > Tagging the 1.0 release:
 >   http://projects.scipy.org/scipy/numpy/changeset/3396/tags/1.0
 >
 > Are you sure that you weren't upgrading from a beta instead of the  
1.0 release?
 >


More information about the Numpy-discussion mailing list