[Numpy-discussion] Build numpy without support of "long double' on OS-X

Steve Lianoglou lists.steve at arachnedesign.net
Thu Jan 25 21:16:08 CST 2007


>> Generally speaking, you need to build binaries on the lowest- 
>> versioned OS X that
>> you intend to run on.
>>
> The problem with building on 10.3 is that it generally comes only with
> gcc 3.3.   I remember that some things require gcc4 - right ?

I think that might only bite you if you want to compile universal  
binaries, though I'm not sure if there are any other problems w/  
gcc3.3, I'm pretty sure that's the big one.

Of course .. that really shouldn't matter if you're just compiling it  
for yourself for just that cpu.

-steve


More information about the Numpy-discussion mailing list