[Numpy-discussion] Different results from repeated calculation

Charles R Harris charlesr.harris at gmail.com
Sun Jan 28 11:24:22 CST 2007


On 1/28/07, Keith Goodman <kwgoodman at gmail.com> wrote:
>
> On 1/27/07, Keith Goodman <kwgoodman at gmail.com> wrote:
> > On 1/27/07, Fernando Perez <fperez.net at gmail.com> wrote:
> > > It's definitely looking like something SMP related: on my laptop, with
> > > everything other than the hardware being identical (Linux distro,
> > > kernel, numpy build, etc), I can't make it fail no matter how I muck
> > > with it.  I always get '0 differences'.
> > >
> > > The desktop is a dual-core AMD Athlon as indicated before, the laptop
> > > is an oldie Pentium III.  They both run the same SMP-aware Ubuntu i686
> > > kernel, since Ubuntu now ships a unified kernel, though obviously on
> > > the laptop the SMP code isn't active.
> >
> > After installing a kernel that is not smp aware, I still have the same
> problem.
>
> The problem goes away if I remove atlas (atlas3-sse2 for me). But that
> just introduces another problem: slowness.
>
> So is this something to report to Clint Whaley? Or does it have to do
> with how numpy uses atlas?



Interesting, I wonder if ATLAS is resetting the FPU flags and changing the
rounding mode? It is just the LSB of the mantissa that  looks to be
changing. Before reporting the problem it might be good to pin it down a bit
more if possible.

How come your computation is so sensitive to these small effects?

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20070128/10af59e9/attachment.html 


More information about the Numpy-discussion mailing list