[Numpy-discussion] NumPy/SciPy LAPACK version

Kevin Jacobs <jacobs@bioinformed.com> bioinformed@gmail....
Mon Jul 16 14:34:29 CDT 2007


On 7/16/07, Robert Kern <robert.kern@gmail.com> wrote:
>
> And we'd certainly appreciate the contribution. I'm tentatively going to
> say
> yes, we should start requiring LAPACK 3.0 unless if there is some very
> important
> platform that only comes with an older LAPACK.
>

Great!  The added benefit is that the calc_work module effectively goes
away, at least in its current form.  I've checked that the current versions
of the major platform-optimized math libraries all use 3.0 or greater,
including Sun's math performance library, Intel MKL, and AMD's ACML.  If one
is willing to forgo vendor-supplied platform optimizations, then
ATLAS+LAPACK or just Netlib LAPACK should suffice for many users.

-Kevin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20070716/1342ed83/attachment.html 


More information about the Numpy-discussion mailing list