[Numpy-discussion] numpy with python < 2.3?

Joël Schaerer joel.schaerer@creatis.insa-lyon...
Thu Jun 14 09:22:00 CDT 2007


Hi there,

I'm trying to install numpy on a system I don't control, which has
python 2.2.3. When I run python setup.py build, I get:

python setup.py build
Running from numpy source directory.
Traceback (most recent call last):
  File "setup.py", line 91, in ?
    setup_package()
  File "setup.py", line 61, in setup_package
    from numpy.distutils.core import setup
  File "numpy/distutils/__init__.py", line 5, in ?
    import ccompiler
  File "numpy/distutils/ccompiler.py", line 11, in ?
    from numpy.distutils import log
  File "numpy/distutils/log.py", line 4, in ?
    from distutils.log import *
ImportError: No module named log

I checked in the documentation and found out that the log module was
first introduced in python 2.3. Does that mean numpy is incompatible
with python < 2.3? Is there a workaround?

joel

PS: please CC me in the answer as I have not subscribed (yet!) to the
list







More information about the Numpy-discussion mailing list