[Numpy-discussion] problem with installing scipy

Sebastian Haase haase@msg.ucsf....
Wed Mar 14 11:54:34 CDT 2007


On 3/2/07, nevin <znevingerek@gmail.com> wrote:
> I am trying to use scipy optimize module but I am having problem when
> I try to import it:
>
> >>> import numpy
> >>> import scipy
> >>> from scipy import optimize
> Traceback (most recent call last):
> File "<stdin>", line 1, in ?
> File "/Library/Frameworks/Python.framework/Versions/2.4/lib/
> python2.4/site-packages/scipy/optimize/__init__.py", line 7, in ?
>    from optimize import *
> File "/Library/Frameworks/Python.framework/Versions/2.4/lib/
> python2.4/site-packages/scipy/optimize/optimize.py", line 25, in ?
>    import linesearch
> File "/Library/Frameworks/Python.framework/Versions/2.4/lib/
> python2.4/site-packages/scipy/optimize/linesearch.py", line 3, in ?
>    import minpack2
> ImportError: Inappropriate file type for dynamic loading
>
> How can I fix this problem? My system is Mac OSX Tiger- Pentium.
> Thanks.

Hi Nevin,

I got the same error message -- your scipy package is for non-Intel (PPC) !

You either have to recompile scipy yourself -- which requires a
working fortran compiler -- or hope that someone knows where to get a
pre-compiled version for Intel.
-Sebastian


More information about the Numpy-discussion mailing list