[Numpy-discussion] Problem with numpy on Leopard

Brian Granger ellisonbg.net@gmail....
Thu Nov 1 15:52:36 CDT 2007


More evidence that just using the python.org python binary isn't a
universal fix for everyone:

>From a thread on one of the python-dev lists:

> Which reminds me -- what version of Python is in Leopard?

2.5.1 + most of the patches that will be in 2.5.2 + some additional
patches by Apple. AFAIK the latter are some patches to support their
build machinery and patches that add support for DTrace.

On 11/1/07, Robert Kern <robert.kern@gmail.com> wrote:
> Matthieu Brucher wrote:
> > Hi,
> >
> > The problem will arise for every package, not only numpy, so Apple
> > fixing this is the best solution IMHO.
>
> It's unlikely they are going to. If they put that stuff there, it's because they
> are using it for something, not as an (in)convenience to you. I don't recommend
> using the Python.framework in /System for anything except for distributing
> lightweight .apps. In that case, you can control your sys.path very well. For
> regular work, use the binary from www.python.org.
>
> --
> Robert Kern
>
> "I have come to believe that the whole world is an enigma, a harmless enigma
>  that is made terrible by our own mad attempt to interpret it as though it had
>  an underlying truth."
>   -- Umberto Eco
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion
>


More information about the Numpy-discussion mailing list