[Numpy-discussion] fortran 90 compiler problem

Lou Pecora lou_boog2000@yahoo....
Wed Oct 10 14:31:54 CDT 2007


--- humufr@yahoo.fr wrote:

> 		Hello,
> 
> I'm using the last svn version of numpy (.
> 
> I tried the solution found on the mail list:
> 
> python setup.py config_fc --fcompiler=gnu95 build
> 
> the two interesting part (at least for me) in the
> building process are:
> 
> customize GnuFCompiler Found executable /usr/bin/g77
> 
> gnu: no Fortran 90 compiler found
> gnu: no Fortran 90 compiler found 

[cut]

I had a similar problem (not sure if it's yours).  I
was told to install the gfortran compiler for scipy
and numpy.  I did and that enabled the install.

Here are my notes.  I hope they are understandable and
they help.  I think Robert Kern straightened me out on
this, so he gets the credit.  If I'm wrong, of course,
that's not Robert's fault.  

* Installing gfortran (needed for SciPy & NumPy):

 Get gfortran from  http://r.research.att.com/tools/
(.dmg file)

 Run the install package on the .dmg. (note it gives
you an uninstall, too)

 Add the paths /usr/local and /usr/local/bin to the
$PATH variable in the .profile startup file so other
apps can access the compiler and related stuff


Let me know if it works.  I like to keep on top of
this since these things seem to change at times and
little things like this can trip you up.




-- Lou Pecora,   my views are my own.


       
____________________________________________________________________________________
Be a better Globetrotter. Get better travel answers from someone who knows. Yahoo! Answers - Check it out.
http://answers.yahoo.com/dir/?link=list&sid=396545469


More information about the Numpy-discussion mailing list