[Numpy-discussion] [Announce] numpy.scons , ALPHA version

Matthieu Brucher matthieu.brucher@gmail....
Fri Oct 26 09:37:02 CDT 2007


>
> What does NOT work
> ==================
>
> One important target missing is windows 64, but this should not be too
> difficult to solve.
>
> There are still many corner cases not yet solved (in particular some
> windows things, most libraries path cannot yet be overriden in
> site.cfg); also, I do not attempt to be 100 % backward compatible with
> the current build system (that for a given environment, you won't
> necessarily have the same build options). Some things are not yet
> supported either (overriding libraries with env variables, for example,
> is not supported).


I would add that MSVC 2005 (windows32) does not work either as it needs a
modification in the SharedLibrary builder (which I can provide if you can
check the version of MSVC).
This would enable people that cannot compile extensions with distutils to
compile them with a compiler they can freely download on the net.

-- 
French PhD student
Website : http://miles.developpez.com/
Blogs : http://matt.eifelle.com and http://blog.developpez.com/?blog=92
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20071026/d2a4b2ac/attachment-0001.html 


More information about the Numpy-discussion mailing list