[Numpy-discussion] Compiling numpy with 64 bits support under Solaris

David Cournapeau david@ar.media.kyoto-u.ac...
Fri Sep 14 02:26:56 CDT 2007


Langella Raphael wrote:
> Hi,
> I'm trying to compile numpy with 64 bits support under 
> Sparc/Solaris 8. I've already compiled Python 2.5.1 with 64 
> bits. I've set up my environnement with :
>
> export CC="gcc -mcpu=v9 -m64 -D_LARGEFILE64_SOURCE=1"
> export CXX="g++ -mcpu=v9 -m64 -D_LARGEFILE64_SOURCE=1"
> export LDFLAGS='-mcpu=v9 -m64'
> export LDDFLAGS='-mcpu=v9 -m64 -G'
>
>   
I am afraid this won't work really well, because it overwrites LDFLAGS. 
Unfortunately, AFAIK, there is no easy way to change flags used for 
compilation and linking. I don't think this is linked to 32 vs 64 bits 
problem (though I may be wrong; I don't know much about solaris).
> I also compiled blas and lapack in 64 bits. I know I don't 
> need them for numpy, but I will soon when I'll compile scipy. 
> I've tried to set up my site.cfg, tu use libfblas and 
> libflapack and it didn't work. I tried libsunperf and got the 
> same result :
>   
See 
http://projects.scipy.org/pipermail/scipy-user/2007-September/013580.html 
(the problem being about the sun compilers, I think this applies to 
sparc as well).

cheers,

David


More information about the Numpy-discussion mailing list