[Numpy-discussion] numpyx.pyx (recent svn) works?

Gael Varoquaux gael.varoquaux@normalesup....
Tue Apr 8 18:31:47 CDT 2008


On Tue, Apr 08, 2008 at 04:28:11PM -0700, Fernando Perez wrote:
> I *could* make it pyrex/cython-valid, it's trivial but just adds noise
> IMHO...  As Stefan said, pyrex is essentially unmaintained as far as
> publicly-visible development goes, while cython is very actively
> moving ahead and likely picking up better numpy support soon (thanks
> to Dag and other GSoC work), so why not just follow that?

Because Cython is not yet shipped be all the major distros (including not
Enthought's EPD current Beta, AFAIK), so it rules out a fair amount of
people who cannot/do not want to install something not shipped.

Note that I don't care that much amount this issue. I am just explaining
why I think it should be after 1.0.5 ships.

Cheers,

Gaël


More information about the Numpy-discussion mailing list