[Numpy-discussion] Win32 installer: please test it

David Cournapeau david@ar.media.kyoto-u.ac...
Mon Apr 14 21:09:30 CDT 2008


Bruce Southey wrote:
> Hi,
> The installer requires 2.5 but that is not explicitly stated. Given
> that numpy and scipy technically require Python 2.3 as a minimum, the
> installer should support Python 2.3 and Python 2.4. Otherwise, it
> needs to clearly state that Python 2.5 is a must.
>   

Stricly speaking, when numpy says it supports all python starting at 
2.3, this does not mean we have to provide binaries for all versions. It 
means that the code itself is compatible.

That being said, the posted installer was just a test version. We will 
do just as before, that is provide a separate installer for python 2.3, 
2.4 and 2.5.

cheers,

David


More information about the Numpy-discussion mailing list