[Numpy-discussion] Release of NumPy

David Cournapeau david@ar.media.kyoto-u.ac...
Tue Apr 15 01:41:29 CDT 2008


Robert Kern wrote:
>
> -lots. I don't want to break API compatibility again no matter what
> version number we bump to, 1.1, 2.0, or 24. It is simply not okay to
> do this again and again.
>
>   

I didn't dare saying anything, but now that I see I am not the only one, 
I can sheepishly say I agree more than 100 %. At some point, we will 
really have to stop breaking api every few weeks. That was ok when numpy 
was not 1.*, but as numpy will - hopefully - get some bigger traction, 
it will just become unmanageable to keep breaking things, users will 
hate it.

This is so much more important than import conventions and other details 
when you have a large user-base :)

cheers,

David


More information about the Numpy-discussion mailing list