[Numpy-discussion] bz2

Charles Doutriaux doutriaux1@llnl....
Thu Apr 17 14:12:06 CDT 2008


Hi,

Just so you know, yesterday i was doing some test on a fresh ubuntu 
installation, trying to figure out the external minimum dependencies for 
our system.

I built (from sources) python (2.5.2)  then numpy.

All seemed ok, but when importing numpy i had an error, trying to import 
module bz2

Turns out Python didn't build with bz2 because the bz2 devel package 
wasn't in.

I'm just reporting this to you guys, has you may want to add a test for 
bz2 in your setup.py before going ahead and build the whole thing.

Hope this helps,

C.



More information about the Numpy-discussion mailing list