[Numpy-discussion] [matplotlib-devel] Numpy 1.1.0 and matplotlib 0.90.1

Eric Firing efiring@hawaii....
Tue Apr 22 13:29:09 CDT 2008


This is inherent; mpl 0.90.1 is permanently incompatible with numpy 1.1, 
short of each user making the change suggested below.  The earliest mpl 
that should work with numpy 1.1 is 0.91.2.

The change in masked array module is a major reason why numpy is getting 
a version bump to 1.1.0 instead of 1.0.5.

Eric

Michael Droettboom wrote:
> I will forward it to the matplotlib-devel mailing list on your behalf.
> 
> Cheers,
> Mike
> 
> lorenzo bolla wrote:
>> Hello,
>>
>> the latest svn numpy version 1.1.0.dev5061 does not work with 
>> matplotlib 0.90.1 (version shipped with enthought distribution), 
>> unless a change in 
>> Python25/Lib/site-packages/matplotlib-0.90.1.0003-py2.5-win32.egg/matplotlib/numerix/ma/__init__.py 
>> is done:
>>
>> $ diff __init__.py.orig __init__.py
>> 12c12
>> <     from numpy.core.ma <http://numpy.core.ma> import *
>> ---
>>>     from numpy.ma <http://numpy.ma> import *
>> Maybe this should be forwarded to the pylab mailing list, but I'm not 
>> subscribed there...
>>
>> L.
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> Numpy-discussion mailing list
>> Numpy-discussion@scipy.org
>> http://projects.scipy.org/mailman/listinfo/numpy-discussion
>>   
> 



More information about the Numpy-discussion mailing list