[Numpy-discussion] Changeset 5609 of numpy breaks scipy build

Fernando Perez fperez.net@gmail....
Tue Aug 5 18:20:06 CDT 2008


Howdy,

I just noticed that scipy wasn't building via my little script that
does a numpy/mpl/scipy svn update+clean build.   Chris Burn's
excellent hunch pinpointed the culprit:

http://projects.scipy.org/scipy/numpy/changeset/5609

Innocent looking as it may be, with numpy after that revision,
building current scipy SVN gives:

creating build/temp.linux-x86_64-2.5/scipy/sparse/sparsetools
compile options:
'-I/home/fperez/usr/opt/lib/python2.5/site-packages/numpy/core/include
-I/usr/include/python2.5 -c'
g++: scipy/sparse/sparsetools/csr_wrap.cxx
scipy/sparse/sparsetools/csr_wrap.cxx: In function 'int
require_size(PyArrayObject*, npy_intp*, int)':
scipy/sparse/sparsetools/csr_wrap.cxx:2902: error: expected `)' before 'PRIdPTR'
scipy/sparse/sparsetools/csr_wrap.cxx:2902: warning: spurious trailing
'%' in format
scipy/sparse/sparsetools/csr_wrap.cxx:2902: warning: too many
arguments for format
scipy/sparse/sparsetools/csr_wrap.cxx:2909: error: expected `)' before 'PRIdPTR'
scipy/sparse/sparsetools/csr_wrap.cxx:2909: warning: spurious trailing
'%' in format
scipy/sparse/sparsetools/csr_wrap.cxx:2909: warning: too many
arguments for format
scipy/sparse/sparsetools/csr_wrap.cxx: In function 'int
require_size(PyArrayObject*, npy_intp*, int)':
scipy/sparse/sparsetools/csr_wrap.cxx:2902: error: expected `)' before 'PRIdPTR'
scipy/sparse/sparsetools/csr_wrap.cxx:2902: warning: spurious trailing
'%' in format
scipy/sparse/sparsetools/csr_wrap.cxx:2902: warning: too many
arguments for format
scipy/sparse/sparsetools/csr_wrap.cxx:2909: error: expected `)' before 'PRIdPTR'
scipy/sparse/sparsetools/csr_wrap.cxx:2909: warning: spurious trailing
'%' in format
scipy/sparse/sparsetools/csr_wrap.cxx:2909: warning: too many
arguments for format
error: Command "g++ -pthread -fno-strict-aliasing -DNDEBUG -O2 -g
-pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC
-fPIC -I/home/fperez/usr/opt/lib/python2.5/site-packages/numpy/core/include
-I/usr/include/python2.5 -c scipy/sparse/sparsetools/csr_wrap.cxx -o
build/temp.linux-x86_64-2.5/scipy/sparse/sparsetools/csr_wrap.o"
failed with exit status 1


###

I don't know what the right solution needs to be, but I figured we'd
at least report it quickly so it can be looked into.

Cheers,

f


More information about the Numpy-discussion mailing list