[Numpy-discussion] Python2.4 support

David Cournapeau david@ar.media.kyoto-u.ac...
Sun Dec 7 23:42:53 CST 2008


Jarrod Millman wrote:
> On Sun, Dec 7, 2008 at 12:02 PM, Pierre GM <pgmdevlist@gmail.com> wrote:
>   
>> * What versions of Python should be supported by what version of
>> numpy ? Are we to expect users to rely on Python2.5 for the upcoming
>> 1.3.x ? Could we have some kind of timeline on the trac site or
>> elsewhere (and if such a timeline exists already, can I get the link?) ?
>>     
>
> NumPy 1.3.x should work with Python 2.4, 2.5, and 2.6.  At some point
> we can drop 2.4, but I would like to wait a bit since we just dropped
> 2.3 support.  The timeline is on the trac site:
>   http://projects.scipy.org/scipy/numpy/milestone/1.3.0
>   

I am strongly against dropping 2.4 support anytime soon. I haven't seen
a strong rationale for using >= 2.5 features in numpy, supporting 2.4 is
not so hard, and 2.4 is still the default python version on many OS (mac
os X 10.4 I believe, RHEL for sure, open solaris).

David


More information about the Numpy-discussion mailing list