[Numpy-discussion] Singular Matrix problem with Matplitlib in Numpy (Windows - AMD64)

George Goussard gwg@emss.co...
Fri Dec 12 01:28:30 CST 2008


Hello David.

I am using the Intel MKL BLAS/LAPACK. I have replaced this with AMD's ACML library. Now there is no exception raised due to a "Singular matrix" while trying to move the legend(wiggling the graph). So, the graph is updated and the interaction is fine(you can wiggle the graph and it updates, minimize, maximeie etc.). But ... the legend is now only drawn sometimes and the graphs are drawn with an intermittent line, as if the - - -  pattern was specified. Something is still not right. I just can't seem to put my finger on it since there are some many parties involved(numpy,matplotlib,python, ctypes etc.)

I also ran the numpy.test() with NUmpy that I compiled with AMD's ACML. The results are included:

Running unit tests for numpy
NumPy version 1.2.1
Results of numpy.test()

NumPy is installed in C:\Development\Python\2_5_2\lib\site-packages\numpy
Python version 2.5.2 (r252:60911, Dec 12 2008, 08:38:07) [MSC v.1400 64 bit (AMD64)]
nose version 0.10.4
Forcing DISTUTILS_USE_SDK=1
............................................................................................................................................
.........................................................................................................K..K...............................
............................................................................................................................................
.......................K.................................................................................Ignoring "MSVCCompiler instance has
 no attribute '_MSVCCompiler__root'" (I think it is msvccompiler.py bug)
...........................S................................................................................................................
............................................................................................................................................
............................................................................................................................................
............................................................................................................................................
............................................................................................................................................
............................................................................................................................................
............................................................................................................................................
.......................................................................................
----------------------------------------------------------------------
Ran 1592 tests in 10.704s

OK (KNOWNFAIL=3, SKIP=1)
<nose.result.TextTestResult run=1592 errors=0 failures=0>

Thanks.

George.



Message: 3
Date: Tue, 9 Dec 2008 02:43:25 +0900
From: "David Cournapeau" <cournape@gmail.com>
Subject: Re: [Numpy-discussion] Singular Matrix problem with
	Matplitlib in	Numpy (Windows - AMD64)
To: "Discussion of Numerical Python" <numpy-discussion@scipy.org>
Message-ID:
	<5b8d13220812080943g69d4c670jabd6aef66d336e29@mail.gmail.com>
Content-Type: text/plain; charset=UTF-8

On Tue, Dec 9, 2008 at 12:50 AM, George Goussard <gwg@emss.co.za> wrote:
> Hello.
>
>
>
> I have been battling with the following error for the past week. The output
> from the terminal is:
>

What does numpy.test() says ? Did you use an external blas/lapack when
you built numpy for AMD64

David


------------------------------

_______________________________________________
Numpy-discussion mailing list
Numpy-discussion@scipy.org
http://projects.scipy.org/mailman/listinfo/numpy-discussion


End of Numpy-discussion Digest, Vol 27, Issue 22
************************************************


More information about the Numpy-discussion mailing list