[Numpy-discussion] Problems installing numpy on Mac OS 10.4

Alex Donaldson donaldsona@battelle....
Fri Feb 22 18:57:04 CST 2008


I'm trying to install numpy 1.0.4 on my Intel MacBook Pro with Mac OS 10.4
and running Python 2.5.  When I run python setup.py build I get the 
errors below.  Is this a compatibility issue?:
Running from numpy source directory.
non-existing path in 'numpy/distutils': 'site.cfg'
F2PY Version 2_4422
blas_opt_info:
  FOUND:
    extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
    define_macros = [('NO_ATLAS_INFO', 3)]
    extra_compile_args = ['-faltivec',
'-I/System/Library/Frameworks/vecLib.framework/Headers']

lapack_opt_info:
  FOUND:
    extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
    define_macros = [('NO_ATLAS_INFO', 3)]
    extra_compile_args = ['-faltivec']

running build
running config_cc
unifing config_cc, config, build_clib, build_ext, build commands 
--compiler options
running config_fc
unifing config_fc, config, build_clib, build_ext, build commands 
--fcompiler options
running build_src
building py_modules sources
building extension "numpy.core.multiarray" sources
Generating build/src.macosx-10.3-fat-2.5/numpy/core/config.h
customize NAGFCompiler
Could not locate executable f95
customize AbsoftFCompiler
Could not locate executable f90
Could not locate executable f77
customize IBMFCompiler
Could not locate executable xlf90
Could not locate executable xlf
customize IntelFCompiler
Could not locate executable ifort
Could not locate executable ifc
customize GnuFCompiler
Could not locate executable g77
customize Gnu95FCompiler
Could not locate executable gfortran
customize G95FCompiler
Could not locate executable g95

....

SystemError: Failed to test configuration. See previous error messages for 
more information.



More information about the Numpy-discussion mailing list