[Numpy-discussion] Bugs using complex192

Francesc Altet faltet@carabos....
Mon Jan 7 14:16:17 CST 2008


A Monday 07 January 2008, Nils Wagner escrigué:
> On Mon, 7 Jan 2008 19:42:40 +0100
>
>   Francesc Altet <faltet@carabos.com> wrote:
> > A Monday 07 January 2008, Nils Wagner escrigué:
> >> >>> numpy.sqrt(numpy.array([-1.0],
> >>
> >>dtype=numpy.complex192))
> >>
> >> Traceback (most recent call last):
> >>    File "<stdin>", line 1, in <module>
> >> AttributeError: 'module' object has no attribute
> >> 'complex192'
> >>
> >> >>> numpy.__version__
> >>
> >> '1.0.5.dev4673'
> >
> > It seems like you are using a 64-bit platform, and they
> >tend to have
> > complex256 (quad-precision) types instead of complex192
> > (extended-precision) typical in 32-bit platforms.
> >
> > Cheers,
> >
> > --
> >
> >>0,0<   Francesc Altet     http://www.carabos.com/
> >
> > V   V   Cárabos Coop. V.   Enjoy Data
> > "-"
> > _______________________________________________
> > Numpy-discussion mailing list
> > Numpy-discussion@scipy.org
> > http://projects.scipy.org/mailman/listinfo/numpy-discussion
> >
> >>> import numpy
> >>> numpy.sqrt(numpy.array([-1.0], dtype=numpy.complex256))
>
> Segmentation fault
>
> Shall I file a bug report ?

Yes, I think so.

Cheers,

-- 
>0,0<   Francesc Altet     http://www.carabos.com/
V   V   Cárabos Coop. V.   Enjoy Data
 "-"


More information about the Numpy-discussion mailing list