[Numpy-discussion] numpy installation issues

David Cournapeau david@ar.media.kyoto-u.ac...
Mon Jul 7 03:27:40 CDT 2008


Chris Bartels wrote:
> Hi,
>
> I have been trying to install numpy (as a dependancy of matplotlib) on
> cygwin. I would like to use the native cygwin-python numpy install, as
> the cygwin development environment I use is portable on usb disk
> (http://www.dam.brown.edu/people/sezer/software/cygwin/). (Extremely
> useful!)
>
> It would be even better if i can actually install
> numpy/scipy/matplotlib on this portable distribution.
>
> Unfortunately "python setup.py build" does give an error. (I installed
> python with sources, so /usr/lib/python2.5/config is existing. Which
> seemed to be a problem with another python package when I googled for
> this error.)

It looks like you did not install python correctly. I strongly recommend
you to use the python available for cygwin, after having removed the
python you installed from sources. Installing the python package does
give you /usr/lib/python2.5/config, as can be seen on the cygwin package
list.

Once you correctly installed the python package from cygwin, remove the
build directory in numpy sources, and start again. This should get you
further,

cheers,

David


More information about the Numpy-discussion mailing list