[Numpy-discussion] numpy installation issues

David Cournapeau david@ar.media.kyoto-u.ac...
Mon Jul 7 04:16:45 CDT 2008


Chris Bartels wrote:
>
> Sorry, my message was ambiguous: I indeed did this, I installed python
> from the cygwin installer

Ok. Python sources are not needed to build python extensions. Only the
headers and the python runtime are needed.

Basically, the problem is that for some reason, the library path flags
are not passed to the linker, and I thought this was because of a bad
python build (from which numpy build system find those informations).
Now, the most likely reason for the problem is that you have
LIBPATH/LINKFLAGS in your environment. If so, unset them: they do not
work as you would expect with numpy/scipy.

cheers,

David


More information about the Numpy-discussion mailing list