[Numpy-discussion] numpy installation issues

Chris Bartels c.l.l.bartels@gmail....
Mon Jul 7 07:09:09 CDT 2008


Hi David,

Thanks again.

Unfortunately these variables are not set in the environment. (I checked
with 'env'.)
I also reinstalled the cygwin python package (again) and ran  'find . -name
libpython* -print', this gives:

/usr/bin/libpython2.5.dll
/usr/lib/python2.5/config/libpython2.5.dll.a

The /usr/lib/python2.5/config/ directory contains the following files:

Makefile
Setup
Setup.config
Setup.local
config.c
config.c.in
install-sh
libpython2.5.dll.a
makesetup
python.o

But the numpy install is still unable to use these, it gives the same error.

Kind regards,
Chris


On Mon, Jul 7, 2008 at 11:16 AM, David Cournapeau <
david@ar.media.kyoto-u.ac.jp> wrote:

> Chris Bartels wrote:
> >
> > Sorry, my message was ambiguous: I indeed did this, I installed python
> > from the cygwin installer
>
> Ok. Python sources are not needed to build python extensions. Only the
> headers and the python runtime are needed.
>
> Basically, the problem is that for some reason, the library path flags
> are not passed to the linker, and I thought this was because of a bad
> python build (from which numpy build system find those informations).
> Now, the most likely reason for the problem is that you have
> LIBPATH/LINKFLAGS in your environment. If so, unset them: they do not
> work as you would expect with numpy/scipy.
>
> cheers,
>
> David
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20080707/76bc36c5/attachment.html 


More information about the Numpy-discussion mailing list