[Numpy-discussion] numpy with fftw

Frédéric Bastien nouiz@nouiz....
Tue Jul 8 14:14:21 CDT 2008


Hi,

I want to compile numpy so that it use the optimized fftw librairy. In
the site.cfg.example their is a section [fftw3] that I fill with:

[fftw3]
include_dirs = /usr/include
library_dirs = /usr/lib64
fftw3_libs   =   fftw3,         fftw3f
fftw3_opt_libs = fftw3_threads, fftw3f_threads

when I compile it, their is no message that it found it like for the
atlas librairy(optimized blas librairy). numpy.show_config() don't
tell which version of fft it use. How can I know it was well compiled?
I tried comparing the speed of the numpy version in FC9 and the one I
built, but they have the same speed. Here is the code I used to do my
timing:
time python -c "import numpy.fft;a=numpy.random.rand(30000);
for i in xrange(10000):
  numpy.fft.fft(a);
numpy.show_config()"

thanks for your time

Frédéric Bastien


More information about the Numpy-discussion mailing list