[Numpy-discussion] [ANNOUNCE] ETS 3.0.0b1 released!

Gael Varoquaux gael.varoquaux@normalesup....
Thu Jul 31 19:38:43 CDT 2008


On Thu, Jul 31, 2008 at 05:48:02PM -0500, Dave Peterson wrote:
> 	easy_install Mayavi

Just a precision (I just got caught by that), to install mayavi2, the
application, and not just the 3d visualization library that can be used eg in
ipython, you need to do:

easy_install "Mayavi[ui]"

ie the Mayavi project, with the optional ui component. In addition, you
need to choose a toolkit. You can do this with the following command:

easy_install "Traits[ui,wx]"

Finally, under Linux, the above commands will install by default the
packages to your /usr/lib/python2.x/site-packages. If like me you believe
this is owned by the package manager and you would like to install to 
/usr/local/lib/python2.x/site-packages, just use the follwing switch:

easy_install --prefix "Mayavi[ui]"

Gaël


More information about the Numpy-discussion mailing list