[Numpy-discussion] numpy 1.1.0 build can not find lahey (lf95) fortran compiler (short version)

Lewis E. Randerson lranderson@pppl....
Mon Jun 2 10:03:58 CDT 2008


Found the problem.

The pattern in lahey.py differs from the version of Lahey Fujitsu
compiler I have.  Once corrected, the compiler is now found. 

P.S.  One of the libraries defined in the file is also incorrect.
Once I have gotten all the way through the SciPy build and
the users have said all works, I'll send in the version of
the successful lahey.py. 

Thanks for the help.
Also thanks to the original contributor of lahey.py.  It saved
me a lot of time!

--Lew

-----Original Message-----
From: numpy-discussion-bounces@scipy.org
[mailto:numpy-discussion-bounces@scipy.org] On Behalf Of David Cournapeau
Sent: Monday, June 02, 2008 8:23 AM
To: Discussion of Numerical Python
Subject: Re: [Numpy-discussion] numpy 1.1.0 build can not find lahey (lf95)
fortran compiler (short version)

Lewis E. Randerson wrote:
> I am seeing these warnings:
>   warning: build_ext: f77_compiler=lahey is not available.
>   
>   

Hi Lewis,

    What happens when you execute directly the file 
numpy/distutils/fcompiler/lahey.py ?

    cheers,

    David
_______________________________________________
Numpy-discussion mailing list
Numpy-discussion@scipy.org
http://projects.scipy.org/mailman/listinfo/numpy-discussion


More information about the Numpy-discussion mailing list