[Numpy-discussion] Numpy 1.1.0 on Python 2.3?

D.Hendriks (Dennis) D.Hendriks@tue...
Tue Jun 17 08:12:55 CDT 2008


Hello,

After I just upgraded my Numpy from 1.0.3.1 to 1.1.0 and executed (using 
Python 2.3.4):

  python -c 'import numpy; numpy.test()' 

I got:

Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "#######/lib/python2.3/site-packages/numpy/__init__.py", line 
107, in ?
    import ma
  File "#######/lib/python2.3/site-packages/numpy/ma/__init__.py", line 
14, in ?
    import core
  File "#######/lib/python2.3/site-packages/numpy/ma/core.py", line 114, 
in ?
    max_filler.update([(k,-numpy.inf) for k in [numpy.float32, 
numpy.float64]])
AttributeError: keys

It seems Python 2.3 doesn't allow updating dictionaries using a list of 
key-value-pair tuples; it only allows a dictionary as parameter to update().

I could not find anything about Python 2.3 no longer being supported by 
Numpy. Did I miss anything?

Dennis



More information about the Numpy-discussion mailing list