[Numpy-discussion] nosetester.py can't use decorators and work with python2.3

Pierre GM pgmdevlist@gmail....
Thu Jun 26 12:47:06 CDT 2008


On Thursday 26 June 2008 13:37:19 Charles R Harris wrote:
> Hi Alan,
>
> Decorators weren't introduced until Python2.4. I'm not sure what version we
> require now, that information should probably be added to a DEPENDENCY
> file, or maybe the README. Anyway, if we still support Python2.3 we can't
> use decorators.

I thought Python2.3 was supported for the 1.1.x branches only, not the 1.2 
one. If the nosetester approach works for 1.2.x, then we should be OK, no?



More information about the Numpy-discussion mailing list