[Numpy-discussion] Installing numpy/scipy on CentOS 4

Chris Miller centos@scratchspace....
Mon May 12 14:39:43 CDT 2008


Robert Kern wrote:
> On Mon, May 12, 2008 at 2:19 PM, Chris Miller <centos@scratchspace.com> wrote:

>>  On the f77 stuff, I read specifically to delete the gcc-f77 package
>>  as that conflicts with gcc-gfortran. The latter we are using is
>>  actually gcc4 not gcc3 (fyi). I see in Atlas that G77 is defined as
>>  gfortran, so this may not be an issue.
> 
> It's still called libf77blas regardless. Well, you don't have ATLAS
> installed. Or if you do, it's an extremely weird installation of
> ATLAS.
> 
> Can you show me a list of files in the RPM that you installed? I don't
> know the rpm command off-hand. Since these are David Cournapeau's
> RPMs, perhaps he can chime in, here.

I think you hit the nail on the head, we need the -devel package 
which would contain the files in /usr/lib. All this RPM has is the 
shared objects :

# rpm -ql atlas
/usr/lib/atlas/sse2/libblas.so.3.0
/usr/lib/atlas/sse2/liblapack.so.3.0


David, do you have an Atlas spec file that builds the -devel package?

Chris


More information about the Numpy-discussion mailing list