[Numpy-discussion] Installing numpy/scipy on CentOS 4

David Cournapeau david@ar.media.kyoto-u.ac...
Mon May 12 20:30:19 CDT 2008


Chris Miller wrote:
> Hello,
> 	I'm having trouble getting the python-numpy RPM to build under
> CentOS 4.6. I've already built and installed atlas, lapack3 and
> refblas3 from the CentOS 5 source RPMS, but numpy won't build
> correctly. Although the ultimate error may be unrelated to Atlas,
> clearly not all the atlas dependencies are being satisfied. Only the
> .so files are supplied by the RPMS, but it seems that some
> additional lib* files may be needed as well.

The problem is that rpm is a mess, and each distribution needs special 
casing because they can't agree on what to put where. If you look at the 
rpm spec file, you will see that it is special cased for CENTOS/RHEL. I 
used version 5 because that's the only one available on the build 
system. You could change that to version 4 and see what happens.

cheers,

David


More information about the Numpy-discussion mailing list