[Numpy-discussion] Getting pylint to recognize numpy

Robert Westerfield robwesterfield@gmail....
Sat May 17 16:40:58 CDT 2008


On 5/17/08, Pierre GM <pgmdevlist@gmail.com> wrote:
> On Saturday 17 May 2008 16:57:58 Robert Kern wrote:
> > On Sat, May 17, 2008 at 3:49 PM, Robert Westerfield
> >
> > <robwesterfield@gmail.com> wrote:
> > > Hi,
> > >
> > > I am unable to get the incredibly useful pylint (0.14) to recognize
> > > numpy.
>
> mmh, works great on my machine...
> pylint 0.14.0,
> astng 0.17.2, common 0.21.2
> Python 2.4.4 (#1, Apr  8 2008, 13:36:41)
> [GCC 4.1.2 (Gentoo 4.1.2 p1.0.1)]
>
> AAMOF, I use eclipse+pydev, that supports pylint. No particular problems
> either...

Thanks Pierre - I am using the same versions for all packages on
Windows (I have tried a newer common as well).

Did you (or Gentoo) do anything particular with either pylint's
configuration file or Eclipse/PyDev to have it pick up numpy?

I've asked on logilab's lists as well.

Kind regards, Rob.

> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion
>


More information about the Numpy-discussion mailing list