[Numpy-discussion] Buildbot errors.

Charles R Harris charlesr.harris@gmail....
Sat May 24 10:03:14 CDT 2008


On Sat, May 24, 2008 at 8:47 AM, Charles R Harris <charlesr.harris@gmail.com>
wrote:

>
>
> On Sat, May 24, 2008 at 12:25 AM, Jarrod Millman <millman@berkeley.edu>
> wrote:
>
>> On Thu, May 22, 2008 at 11:25 PM, Charles R Harris
>> <charlesr.harris@gmail.com> wrote:
>> > On Fri, May 23, 2008 at 12:10 AM, Charles R Harris
>> > <charlesr.harris@gmail.com> wrote:
>> >>
>> >> The python 2.6 buildbots are showing 5 failures that are being hidden
>> by
>> >> valgrind.
>> >
>> > They seem to have fixed themselves,  they were probably related to the
>> API
>> > addition I made, then moved. However, it is a bad thing that the errors
>> were
>> > covered up by Valgrind and not reported.
>>
>> I didn't understand what you meant by this yesterday, but I see what
>> you are talking about now:
>>
>> http://buildbot.scipy.org/builders/Linux_x86_64_Fedora/builds/486/steps/shell_2/logs/stdio
>>
>> http://buildbot.scipy.org/builders/Linux_x86_Fedora_Py2.6/builds/461/steps/shell_2/logs/stdio
>>
>> You said they fixed themselves, but the failures are in the most
>> recent buildbot reports.  This is the only thing I am concerned about
>> before branching, so hopefully someone can look at this and let me
>> know whether the failures are indeed fixed.
>>
>
> That's  actually a bit different, I saw the 5 failures after the main
> sequence of tests and those are OK now. Valgrind seems to run things twice
> and the new failures are in the valgrind tests, I missed those.
>

I take that back,  I got confused looking through the output. The errors are
the same and only seem to happen when valgrind runs the tests.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20080524/6b8877d5/attachment-0001.html 


More information about the Numpy-discussion mailing list