[Numpy-discussion] 1.1.x branch and 1.1.0 tag imminent

Anne Archibald peridot.faceted@gmail....
Sat May 24 14:35:54 CDT 2008


2008/5/24 Jarrod Millman <millman@berkeley.edu>:
> On Fri, May 23, 2008 at 11:16 PM, David Cournapeau
> <david@ar.media.kyoto-u.ac.jp> wrote:
>> Where do those errors appear ? I don't see them on the builbot. Are they
>> 2.6 specific ? If yes, I would say ignore them, because 2.6 is not
>> released yet, and is scheduled for september.
>
> You can see them here:
> http://buildbot.scipy.org/builders/Linux_x86_64_Fedora/builds/486/steps/shell_2/logs/stdio
> http://buildbot.scipy.org/builders/Linux_x86_Fedora_Py2.6/builds/461/steps/shell_2/logs/stdio
>
> You have to search for them, because as Chuck pointed out it seems
> valgrind seems to be hiding them.  We should figure out how to avoid
> this at some point down the road as well.
>
> I am not sure whether or not this is 2.6 specific or not.

No. These are a known limitation of valgrind when dealing with
floating-point. Other than emailing the valgrind developers to tell
them that yes, somebody cares about this, I think they can be safely
ignored (thank goodness).

Anne


More information about the Numpy-discussion mailing list