[Numpy-discussion] New ufuncs
Wed Nov 5 14:45:58 CST 2008
On Wed, Nov 5, 2008 at 12:00 PM, Charles R Harris
> Hmm.... I wonder if the base function should be renamed logaddexp, then
> logsumexp would apply to the reduce method. Thoughts?
As David mentioned, logsumexp is probably the traditional name, but as
the earlier link shows, it also goes by logadd. Given the distinction
between add (a ufunc) and sum (something done over an axis) within
numpy, it seems that logadd or logaddexp is probably a more fitting
name. So long as it is documented, I doubt it matters much though...
More information about the Numpy-discussion