[Numpy-discussion] New ufuncs
Charles R Harris
Wed Nov 5 16:09:17 CST 2008
On Wed, Nov 5, 2008 at 2:41 PM, Stéfan van der Walt <firstname.lastname@example.org>wrote:
> 2008/11/5 T J <email@example.com>:
> > numpy, it seems that logadd or logaddexp is probably a more fitting
> > name. So long as it is documented, I doubt it matters much though...
> Please don't call it logadd. `logaddexp` or `logsumexp` are both
> fine, but the `exp` part is essential in emphasising that you are not
> calculating a+b using logs.
I'm inclined to go with logaddexp and add logsumexp as an alias for
logaddexp.reduce. But I'll wait until tomorrow to see if there are more
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Numpy-discussion