[Numpy-discussion] How to force build of included LAPACK?

Charles R Harris charlesr.harris@gmail....
Fri Nov 14 19:13:40 CST 2008


On Fri, Nov 14, 2008 at 5:31 PM, Robert Kern <robert.kern@gmail.com> wrote:

> On Fri, Nov 14, 2008 at 16:53, Charles R Harris
> <charlesr.harris@gmail.com> wrote:
> > All,
> >
> > I recall seeing this before, but I can' find it in a search. The question
> is
> > how to force numpy to ignore any present blas/lapack and use it's own.
>
> Hmm, tricky. I don't think there is a good way. On OS X, lapack_opt
> pretty eagerly tries to accept Accelerate.framework. You can fake it
> out by using ATLAS=1 (but you must not have ATLAS or anything else).
> On other platforms, you can probably use ATLAS=None (though Lord help
> you if you have MKL, too).
>

Might be worth putting a flag in site.cfg just in case someone gets stuck
with a broken library that they can't remove.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20081114/9c15f82a/attachment.html 


More information about the Numpy-discussion mailing list