[Numpy-discussion] Proposal for changing the names of inverse trigonometrical/hyperbolic functions

Jon Wright wright@esrf...
Mon Nov 24 14:00:48 CST 2008


Eric Firing wrote:
> Francesc Alted wrote:
>
>> So, IMHO, I think it would be better to rename the inverse trigonometric 
>> functions from ``arc*`` to ``a*`` prefix. 
>
> +1
> I have stumbled over this myself.  If there is resistance to removing 

-1

There is resistance. Please don't remove the old names. Also note that 
your proposed change will alter people's code in subtle, but potentially 
very "interesting" ways:

>>> from math import *
>>> from numpy import *
>>> type(arcsin(1)) is type(asin(1))
False
>>> from numpy import arcsin as transformacion_del_arco_seno
>>> arcsin == transformacion_del_arco_seno
True

asin(1j) raises an exception, arcsin doesn't. They are *different* 
functions, hence the names.

I have the feeling the only times I ever write to this list is to say 
"please don't change the API". So, here I am again, "please don't change 
the API". This is a cosmetic change whose only effect seems to be to 
have everyone change their code, and then support multiple incompatible 
numpy versions.

Thanks,

Jon




More information about the Numpy-discussion mailing list