[Numpy-discussion] Proposal for changing the names of inverse trigonometrical/hyperbolic functions
Mon Nov 24 18:40:16 CST 2008
Matthew Brett wrote:
> numpy.asum numpy.arange numpy.amax etc all have the intended meaning
> of 'a-for-array-version-of-function'. This obviously isn't the case
> for 'acos'.
actually, it is, isn't it? a version of math.cos that works for arrays?
But anyway, if we had it to do all over again, I'd never suggest that
anyone use "import *", and I would have called all those numpy.range,
no, I'm not suggesting that we break the API now....
Christopher Barker, Ph.D.
Emergency Response Division
NOAA/NOS/OR&R (206) 526-6959 voice
7600 Sand Point Way NE (206) 526-6329 fax
Seattle, WA 98115 (206) 526-6317 main reception
More information about the Numpy-discussion