[Numpy-discussion] Name changes and suggested file name change for Pauli.
Charles R Harris
Thu Nov 27 23:53:36 CST 2008
I'm thinking of changing the names of fmax and fmin to fmaximum and fminimum
so that fmax and fmin can play the roles corresponding to max and min.
Should I add the names atanh, asinh, and acosh as aliases for arctanh,
arcsinh, and arccosh? The vote looked pretty evenly split. If we add them, I
suggest we merely add a note to the documentation of the old functions
suggesting use of the new names to conform to general practice. A while ago
I added deg2rad and rad2deg as aliases for radians and degrees respectively,
so this can be seen as more of the same.
Pauli, can you change the name of code_generators/docstrings to something
more descriptive? I think ufunc_docstrings would be a bit clearer. I expect
this requires various fixups here and there, so I'm tossing the problem over
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Numpy-discussion