[Numpy-discussion] cannot find numpy 1.2 for python 2.6 on window

Hanni Ali hanni.ali@gmail....
Sun Oct 5 07:08:48 CDT 2008


Hi David,

Yeah nose was an issue, thanks for letting me know about nose compatibility
being sorted that's good news as I use it a bit with my testing.

I last built 1.1.1 with express for 32bit it went fine (although I think you
do have to comment out , I was also able to compile with 2008 full for
64-bit platform, my next goal is to see if i can sort out blas etc. external
libs on 64bit.

>From the "Installation info" thread around the 30th May I had reported the
one oddity I  had encountered with the VS compiler

> In order to get numpy to compile I
> have commented out a small part which was causing compilation to fail:
>
> numpy\core\src\umathmodule.c.src(64) : error C2059: syntax error : 'type'
> numpy\core\src\umathmodule.c.src(70) : error C2059: syntax error : 'type'
>
> This relates to this section of code:
>
> #ifndef HAVE_FREXPF
> static float frexpf(float x, int * i)
> {
>     return (float)frexp((double)(x), i);
> }
> #endif
> #ifndef HAVE_LDEXPF
> static float ldexpf(float x, int i)
> {
>     return (float)ldexp((double)(x), i);
> }
> #endif

At the time I had tried to send further output following a checkout, but
couldn't get it to post to the list, I think the message was too big or
something. I will probably be having a go with 1.2.0, when I get some time.
I'll let you know how it goes.

Cheers,

Hanni


2008/10/5 David Cournapeau <cournape@gmail.com>

> On Sun, Oct 5, 2008 at 8:28 AM, Alan McIntyre <alan.mcintyre@gmail.com>
> wrote:
> > On Sat, Oct 4, 2008 at 11:14 AM, Daniel Wolff <daniel.wolff@gmail.com>
> wrote:
> >> Hello, I recently upgraded to python 2.6. I cannot seem to find the
> >> appropriate numpy install file. I tried to make use of the .exe built
> for
> >> python 2.5 but the installer hung. Any suggestions? Regards, Daniel
> >
> > Hi Daniel,
> >
> > Last I heard, there are still some things that need to be ironed out
> > for NumPy on Python 2.6, so you will probably have to stick with 2.5
> > for a while.  (Somebody please correct me if I'm wrong and there's an
> > imminent release for 2.6 coming up ;)
>
> One thing which was a relatively major stopper was nose, our test
> infrastructure, was not 2.6 compatible, but that has just changed. I
> will look on windows to see if 1.2 can be built with 2008 express,
>
> cheers,
>
> David
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20081005/90ca2170/attachment-0001.html 


More information about the Numpy-discussion mailing list