[Numpy-discussion] can't build numpy 1.2.0 under python 2.6 (windows-amd64) using VS9

David Cournapeau david@ar.media.kyoto-u.ac...
Wed Oct 8 08:40:58 CDT 2008


Peter wrote:
>
> How about python 2.5 and numpy 1.2 instead?  Python 2.6 makes some
> important changes to python 2.5 (in preparation for Python 3.0), so
> you may find several other packages will take a couple of months to
> work 100% with python 2.6 - so check this out if you do plan to use
> more than just numpy.  There are sometimes drawbacks to using brand
> new releases ;)

If I understand Ravi right, one problem with 2.5 is that it relies on an
old toolset (VS 2003, not available anymore). OTOH, 2.6 depends on the
most recent toolset, which is also available for free in a limited
version (VS 2008 express). If you think about supporting things for a
couple of years, relying on VS 2008 sounds safer than 2003.

cheers,

David


More information about the Numpy-discussion mailing list