[Numpy-discussion] can't build numpy 1.2.0 under python 2.6 (windows-amd64) using VS9

Ravi lists_ravi@lavabit....
Wed Oct 8 09:17:42 CDT 2008


On Wednesday 08 October 2008 09:40:58 David Cournapeau wrote:
> > How about python 2.5 and numpy 1.2 instead?  Python 2.6 makes some
> > important changes to python 2.5 (in preparation for Python 3.0), so
> > you may find several other packages will take a couple of months to
> > work 100% with python 2.6 - so check this out if you do plan to use
> > more than just numpy.  There are sometimes drawbacks to using brand
> > new releases ;)
>
> If I understand Ravi right, one problem with 2.5 is that it relies on an
> old toolset (VS 2003, not available anymore). OTOH, 2.6 depends on the
> most recent toolset, which is also available for free in a limited
> version (VS 2008 express). If you think about supporting things for a
> couple of years, relying on VS 2008 sounds safer than 2003.

Absolutely correct. VS 2003 is one of the biggest problems. I know C++ is not 
a favored language in these parts, but a lot of our code relies on Boost, for 
platform neutrality (like filesystem, threading, stdint) and for many other 
utilities (like ublas, wave, tuples, bind). VS 2003 requires too many 
workarounds in my code and support for it may be dropped in Boost some time 
soon: VS 7.0 is already scheduled for to be dropped and VS 7.1 (a.k.a. VS 
2003) is not likely to be supported for much longer. In fact python 2.5.x's 
requirement of VS 2003 is probably the main reason that this compiler is still 
used in a lot of places.

The only python packages that I use are numpy/scipy, matplotlib, pyhdf5, and 
an interprocess communication link with VisIt. To the best of my knowledge, 
all of these work today (in some fashion) with python 2.6 on Linux. Therefore, 
any changes required to make them build on Windows are likely to be compiler-
specific rather than to fix inherent problems related to python 2.6.

Regards,
Ravi




More information about the Numpy-discussion mailing list