[Numpy-discussion] can't build numpy 1.2.0 under python 2.6 (windows-amd64) using VS9

Ravi lists_ravi@lavabit....
Thu Oct 9 16:07:37 CDT 2008


On Wednesday 08 October 2008 10:56:02 Hanni Ali wrote:
> We discussed errors you are encountering a few months ago, they are related
> to the compiler directives.
>
> > #ifndef HAVE_FREXPF
> > static float frexpf(float x, int * i)
> > {
> >     return (float)frexp((double)(x), i);
> > }
> > #endif
> > #ifndef HAVE_LDEXPF
> > static float ldexpf(float x, int i)
> > {
> >     return (float)ldexp((double)(x), i);
> > }
> > #endif
>
> Commenting out this section at line 64 allow compilation and has no ill
> effects.

Given that commenting out the section above allows numpy to compile without 
any apparent side effects, is there any chance we could get "experimental" 
binaries of numpy 1.2.0 for python 2.6? I do understand that a negative answer 
is very likely and the reasons therefor.

Regards,
Ravi




More information about the Numpy-discussion mailing list