[Numpy-discussion] can't build numpy 1.2.0 under python 2.6 (windows-amd64) using VS9

Michael Abshoff michael.abshoff@googlemail....
Fri Oct 10 07:12:37 CDT 2008


David Cournapeau wrote:

Hi David,

> 
> I started a wiki page on the issues related to windows, 64 bits and
> python 2.6 (those issues are somewhat related at some level):
> 
> http://scipy.org/scipy/numpy/wiki/MicrosoftToolchainSupport

Cool.

> If you want to help, you can try solving one problem. In particular, if
> you know how to build ATLAS with Visual studio (for 64 bits support), it
> would be really helpful,

The problem with 64 bit ATLAS support for MSVC is that as is that ATLAS 
uses (AFAIK) assembly code that is not compilable with the MSVC 
toolchain. Since the official MinGW cannot create 64 bit code (there is 
some experimental support I have not tried yet) the only hope at the 
moment (without converting the assembly) to use the Intel toolchain. I 
have not tried that yet.

The current ATLAS code even requires Cygwin, but there was recent 
activity on the ATLAS mailing list to support MinGW only. There are also 
issues with threading support with MinGW to winpthread, so there is some 
work ahead to fully support ATLAS with MSVC.

Clint Whaley is supposed to speak at Sage Days 11 in Austin in about a 
month and I had planned to investigate the possibilities of native 64 
bit ATLAS support for VC9. I had planned to spend some days after SD 11 
at Enthought and work on MSVC build issues as well as 64 bit OSX stuff 
for example, but I need to make plans shortly since I need to buy my 
plane ticket soon

> cheers,
> 
> David

Cheers,

Michael

> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion
> 



More information about the Numpy-discussion mailing list