[Numpy-discussion] can't build numpy 1.2.0 under python 2.6 (windows-amd64) using VS9

Michael Abshoff michael.abshoff@googlemail....
Fri Oct 10 09:51:28 CDT 2008


David Cournapeau wrote:
> Ravi wrote:

Hi,

>> Michael Abshoff already responded to the ATLAS question. I don't have access 
>> to a 64-bit Windows. Given the volume of legacy 32-bit applications where I 
>> work, there is no chance of 64-bit Windows access for me for at least 2 years.
> 
> Windows 64 actually has a very nice feature: WoW (windows on windows).
> It can executes any 32 bits software, AFAIK (which does not run in ring
> 0 of course).

Well, I think that having a 64 bit native build of numpy/scipy using an 
efficient and non-commercial licensed BLAS/Lapack (i.e. not Intel MKL) 
can't be a bad thing :)

>> VS2008 with 32-bit windows should not have any problems (as you mentioned on 
>> the Wiki page referenced above).
> 
> I wish it were true :) I can't build numpy with mingw ATM, because of
> bugs in mingw. Things like:
> 
> http://bugs.python.org/issue3308

It might be possible to build python [2.5|2.6|3.0] with MinGW itself to 
avoid the runtime issue. At least Python 2.4 had problems when building 
it with MinGW and I never investigated if 2.5.x had fixed those issues.

>>  What needs to be done to figure out msvc9 
>> support on mingw and how can I help? I am a Windows n00b (mostly by choice) 
>> when it comes to platform-specific issues.
> 
> Then, I am afraid you won't be of much help, ufortunately.
> 
> cheers,
> 
> David

Cheers,

Michael

> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion
> 



More information about the Numpy-discussion mailing list