[Numpy-discussion] can't build numpy 1.2.0 under python 2.6 (windows-amd64) using VS9

David Cournapeau david@ar.media.kyoto-u.ac...
Fri Oct 10 10:05:16 CDT 2008


Michael Abshoff wrote:
>
> Well, I think that having a 64 bit native build of numpy/scipy using an 
> efficient and non-commercial licensed BLAS/Lapack (i.e. not Intel MKL) 
> can't be a bad thing :)

Yes, of course. But it is useful to be able to use a 32 bits toolchain
to produce 64 bits software.

>
> It might be possible to build python [2.5|2.6|3.0] with MinGW itself to 
> avoid the runtime issue. At least Python 2.4 had problems when building 
> it with MinGW and I never investigated if 2.5.x had fixed those issues.

Not being ABI compatible with Python from python.org is not an option,
and building it with mingw would make it ABI incompatible for sure. I
certainly wished they used an open source compiler to build the official
python binary, but that's not the case.

cheers,

David


More information about the Numpy-discussion mailing list