[Numpy-discussion] Medians that ignore values

David Cournapeau david@ar.media.kyoto-u.ac...
Fri Sep 19 06:26:04 CDT 2008


Peter Saffrey wrote:
> Pierre GM <pgmdevlist <at> gmail.com> writes:
>
>> I think there were some changes on the C side of numpy between 1.0 and 1.1, 
>> you may have to recompile scipy and matplotlib from sources. What versions 
>> are you using for those 2 packages ?
>>
>
> $ dpkg -l | grep scipy
> ii  python-scipy                               0.6.0-8ubuntu1                  
>         scientific tools for Python
>
> $ dpkg -l | grep matplotlib
> ii  python-matplotlib                          0.91.2-0ubuntu1                 
>         Python based plotting system in a style simi
> ii  python-matplotlib-data                     0.91.2-0ubuntu1                 
>         Python based plotting system (data package)
> ii  python-matplotlib-doc                      0.91.2-0ubuntu1                 
>         Python based plotting system (documentation 

If you build numpy from sources, please don't install it into /usr ! It
will more than likely break everything which depends on numpy, as well
as your debian installation (because you will overwrite packages handled
by dpkg). You should really install in a local directory, outside /usr.

You will have to install scipy and matplotlib in any case, too.

cheers,

David


More information about the Numpy-discussion mailing list